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1 Introduction
SSURGO and STATSGO2 are soil data available for the USA and available free from the web.  They 
are a good, detailed source of soil data to use with QSWAT, but they need some preparation first.  This 
document explains how to obtain and prepare SSURGO and STATSGO2 data.

2 Choosing a suitable resolution
We will later be converting soil maps that are shapefiles (also called vector files in QGIS) to grids (also
called rasters).  We will be asked for a resolution to use, and it is sensible to make the resolution  the 
same as the DEM we are using.  Making the resolution smaller is simply wasteful: QSWAT will be 
reading a soil value for each cell in the DEM, so with a smaller resolution some of our soil data will not
be read.  Making the resolution larger potentially loses useful soil data.  So we need to find the 
resolution of our DEM, and this needs to be for the DEM in lat-long projection, since we will be 
converting soil maps when they are in lat-long projection.  We proceed as follows:

 Start QGIS and load your DEM, preferably in a lat-long projection version, but otherwise as it 
is

 Right click on its entry in the Layers panel, and select Save as... 

 The current resolution, horizontal and vertical, is shown in the Resolution box.  If the DEM is 
projected, the resolution will be in metres and will show that one grid cell will be, for example, 
100 x 100 metres in size.  If the DEM is in lat-long (when we also say it is in a geographic 
coordinate system) the units are degrees, and the resolution will typically be a small fraction of 
a degree in each direction.

 If the resolution is in degrees, make a note of the values.  Otherwise, click the Change button 
beside CRS (the coordinate reference system) and in the form that comes up look for the system
WGS84, with EPSG number 4326.  It will probably appear in the Recently used list.  Otherwise 
you need to search for it in the lower box, where it is one of the Geographic Coordinate 
Systems. Select it, so that it appears as WGS 84 in the Selected CRS box, and click OK.  In the 
Save raster layer as... form we see that the resolution values have changed, and we can make a 
note of them.  Then Cancel this form – there is no need to actually save the map.

 The resolutions may be slightly different.  For SWAT's Example1, for example, where the 
projected resolution is 100 x 100, we get values of 0.00108026 and 0.000892786 in lat-long.  
We will simply use 0.001 for both later.

3 Obtaining the maps
It is convenient to start at the USDA's Geospatial Data Gateway http://datagateway.nrcs.usda.gov/  
From there we select Order by bounding rectangle which allows us to input the extent of the area we 
want the soil map for.  We will obtain the maps for SWAT's Example1, a watershed in Texas.  We enter 
longitudes 96W and 95.4W, and latitudes  32.7N and 33.2N.  You don't need to be very accurate with 
these values; make sure you round values away from your area rather than towards it.  Make a note of 
them as you will need them later.

Once you have input the extent, click Check Desired Coordinates to see the area you have selected, and
revise if necessary.  Then click Submit Desired Coordinates.  This brings up a range of maps that you 
can download.  Scroll down to the Soils section and you will see that amongst others we are offered 4 

http://datagateway.nrcs.usda.gov/


SSURGO 2.2 maps, comprising almost 46MB of data, and a single STATSGO2 map comprising over 
12MB.  The STATSGO2 map actually covers all of Texas: it is much less detailed than SSURGO.  
Check whichever of these maps you want and click CONTINUE at the bottom.

On the next page you are informed that the maps will be in ESRI Shape format, that they will be in 
WGS84Geographic projection, and the inclusion option is Extract.  This is all OK.  It will also be 
delivered free by FTP.  Click CONTINUE.

On the next page you enter your contact information.  If you have used this service before this data will
(if you agreed) have been saved.  Complete it if necessary and click CONTINUE.

You then have a final review page which summarises your order.  Click PLACE ORDER.

Next you check your email and you will find links to download your zip file(s).  Click on the link(s) 
and save.

If you open the STATSGO2 zip archive you find a text file with information about the map, and another
zip archive which in turn contains a couple of sub-folders, some metadata files, and an Access 
database.  Navigate to the spatial subfolder, where you can find the shapefile, which comes as four files
with suffixes dbf, prj, shp and shx.  Select or create a folder, somewhere, which we will call the soil 
folder, and copy these four files into it.

If you open the SSURGO zip archive you find a similar structure, except there are 4 inner zip files.  
STATSGO2 is organised by state and SSURGO by county.  We have maps for 4 counties, identified by 
the codes TX231, TX467, TX499, and TX610.  Open the first inner zip archive, for TX231, and again 
navigate to the spatial subfolder.  This time we see a collection of different shapefiles.  The one we 
need is the one containing the string mu_a, namely soilmu_a_tx231.dbf, .prj, .shp and .shx.  Copy those
four files to the soil folder, and repeat for the other three inner zip archives.

From now on we will use the SSURGO data.  The same procedures will apply to STATSGO2, except 
that SSURGO, as in this example, typically involves multiple files instead of just one.

4 Converting shapefiles to grids
SSURGO and STATSGO2 maps are shapefiles, and QSWAT uses grids for soil data.  It would be 
possible for QSWAT to use shapefiles, but reading them point-by-point as we need to do is slower than 
for grids, so it is worth converting them once in advance of running QSWAT..

There are therefore a number of procedures we need to perform to prepare our data:

 converting from shapefiles to grids

 clipping grids to our area of interest

 merging grids

 reprojecting to an “equal area” projection

You might think it would be easiest to merge first, but the size of these files makes this problematic: 
you may well exceed QGIS's capacity.  So we will proceed in the order above.

Start QGIS and load soilmu_a_tx231.shp, using Layer → Add Vector Layer or the corresponding button
on the left of the QGIS window.  Browse to the soil folder, select the file, click Open, click Open again.

Shapefiles associate one or more attributes with their shapes.  If we open the attribute table for a 
SSURGO shapefile (right click on the entry in the Layers panel and select Open Attribute Table) we see
that there are four attributes: AREASYMBOL, SPATIALVER, MUSYM and MUKEY.  We need to choose 



one as the value to be used in the grid, and it must be numeric.  The value we want is MUKEY, but 
unfortunately it is stored as a string.  There is a simple procedure to generate an equivalent numeric 
field.  In the attribute table, click on the Toggle editing mode button (the leftmost) and then on the Field
calculator (the rightmost).  In the Field calculator form (Figure 1) make sure Create a new field is 
checked, enter MUKEYINT as the Output field name, and if necessary change the Output field type to 
Whole number (integer).  Leave the Output field width  as 10.  We create values for the new field by 
creating an expression, which in our case will be toint("MUKEY") (Figure 1).  You can simply type 
this in the Expression box, or you can create it by clicking:

 In Function list, expand Conversions and click twice on toint.

 In Function list, expand Fields and Values, and click twice on MUKEY.

 Under Operators, click on ).

Figure 1: Adding the MUKEYINT field



Click OK and you will see in the attribute table the new attribute MUKEYINT has been added and the 
values inserted.  It is still in editing mode, so click the Toggle editing button, then click Save in the Stop
editing form and close the attribute table.

We are now ready to convert to a grid.  Use Raster → Conversion → Rasterize to open the Rasterize 
(Vector to raster) form (Figure 2).  Select the input shapefile, which will be available in the pull down 
menu, set the Attribute field to MUKEYINT, click the Select button for the Output file, navigate if 
necessary to the soil folder, and provide a suitable name, such as tx231_ll, make sure the file type is 
GeoTIFF, and click Save.  You will be reminded that you need to decide on the grid's size or resolution.
Click OK to remove the reminder.

We enter the resolution values we found earlier, check Load into canvas when finished if necessary, and
click OK.  We are informed when processing is complete – click OK – then shown a progress window 
which we also remove by clicking OK.  Do not close the Rasterize form – we can use it again without 
having to add the details.  Return to the main QGIS window and we see that our raster layer has been 
added and looks rather strange – white where it overlaps the shapefile and black elsewhere.  QGIS has 
difficulty colouring such files: they have a wide range of values with only a few actually occurring.  We
will not worry about it: the final map will be coloured by QSWAT.

5 Clipping grids
Grids can be clipped using an extent, which we recorded earlier when we downloaded the soil maps.  

Figure 2: Converting shapefile to grid



(Shapefiles can only be clipped using another shapefile.  We could have created a suitable clipping 
shapefile by drawing a rectangle to match our extent, but if we convert to grid before clipping we avoid
having to make this shapefile.)   Select the grid in the Layers panel, and use Raster → Extraction → 
Clipper  to bring up the Clipper form (Figure 4).

The Input file should already be chosen, else select it in the pull-down menu.  Click Select next to 
Output file, navigate to the soil folder, and enter a suitable file name, such as tx231_ll_clip.  Make sure 
the file type is GeoTIFF and click Save. In the Clipper form check No data value.  We can leave the 
default no data value of 0 since all SSURGO soil keys are large positive integers.  Enter the extent, 
remembering that west longitudes are entered as negative numbers.  When you complete entering the 
extent it is displayed in the map canvas as a coloured rectangle, so you can see it is where it should be.  
If necessary check Load into canvas when finished (Figure 3) and click OK.  Click OK to remove the 
completion announcement and again to remove the (expected) warning that the extent falls partly 
outside the grid.  Do not close the Clipper form, as we will use it again.  

Returning to the main QGIS window we remove the unclipped grid and the shapefile.

We can now process the other soil shapefiles in the same way.  We proceed as follows:

 Load the next shapefile

 Open its attribute table, toggle editing, and create the field MUKEYINT.  You will find that the 

Figure 3: Clipping a soil grid



expression toint("MUKEY") is already saved under Recent (fieldcalc) and clicking on it twice 
will place it in the Expression box.  Click OK to close the Field calculator, toggle editing, 
confirm the save and close the attribute table.

 The Rasterize form should already be open, and should show the right shapefile (as there is only
one loaded).  The output file name is still the previous one, but you can make the minor edit for 
the new file within the box.  The resolution is unchanged.  Unfortunately, the form does not 
register the new field MUKEYINT, and only shows the field SPATIALVER.  However, it is 
possible to directly edit the GDAL command in the box below.  Click the Edit button beside the 
box, change  SPATIALVER  to  MUKEYINT, and click OK.  Do not click the Edit  button until 
after clicking OK or it will restore the wrong field name.  Click OK to remove the next two 
messages and again do not close the Rasterize form.

 Return to the  Clipper form.  Select the new grid as the input file, edit the output file name and 
leave the remainder unchanged.  Click OK, and click OK to close the following two messages.

 Remove the shapefile and unclipped grid.

After closing the Clipper and Rasterize forms you should be left with a number of grids which together 
cover the extent.

6 Merging grids 
The next task is to merge the grids.  Use Raster → Miscellaneous → Merge to open the Merge form 
(Figure 4).  Click Select beside Input files, navigate to the soil folder, hold down Ctrl and select each of
the _ll_clip.tif files.  Click Open. Click Select beside Output file and type a file name such as soil_ll.  
Check the type is GeoTIFF and click Save.  Back in the Merge form check No data value and leave the 
value as 0.  If necessary check Load into canvas when finished and click OK.  Click OK to close each 
of the two messages.  Close the Merge form.



7 Reprojecting the grid
In QGIS maps can be reprojected by saving in the new projection.  We will save this grid in the Albers 
Equal Area projection used for SWAT's Example1.  We have previously loaded some of the files 
distributed for this example, so QGIS will have stored the projection as one recently used.

Right click on the entry for soil_ll in the Layers panel, and select Save As... to open the Save raster 
layer as… form.  Browse to the soil folder, and type a suitable name, say soil_aea.  Click on Change 
beside CRS to bring up the Coordinate Reference System Selector form (Figure 5).  Find and select the 
relevant entry, and check it appears in the Selected CRS box at the bottom.  Click OK  Back in the Save
raster layer as... form click OK to complete the save.  The grid will not be loaded because its 
projection is different from the current QGIS instance.  You can start another instance of QGIS and 
load it to check it is as expected.  Start QGIS and load the grid.  The colouring is very inadequate, as 
we mentioned earlier.  This will improve when we use it in QSWAT, but in general with SSURGO there

Figure 4: Merging the clipped grids



will be too many discrete soil values for effective colouring.

8 SSURGO/STATSGO2 soil database
SWAT will need the data for the soils.  SSURGO and STATSGO2 use the same database 
SWAT_US_SSURGO_Soils, which must be downloaded from the SWAT website.  Currently it is stored 
on the ArcSWAT page http://swat.tamu.edu/software/arcswat/.  Extract the mdb file from the zip 
archive and place it in the Databases subfolder of the SWAT Editor folder, normally 
C:\SWAT\SWATEditor.  Then QSWAT will find it and pass it to the SWAT Editor for generating the soil 
input files.

Figure 5: Selecting the coordinate reference system

http://swat.tamu.edu/software/arcswat/
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